1.4 Versionsübersicht Wings X

Version 1.2.3 vom 07.12.2022

Neue Funktionen

– Beim Drag & Drop im bzw. ins Storyboard ist es nun möglich Objekte zwischen bestehenden einzufügen, ohne vorher dafür Platz schaffen. Wenn man Objekte in den senkrechten Spalt zwischen zwei Feldern zieht, so werden diese dort eingefügt und die nachfolgenden Felder automatisch nach rechts verschoben. Wenn man Objekte in den horizontalen Spalt zwischen zwei Zeilen zieht, so werden automatisch eine oder mehrere neue Zeilen angelegt, und die Objekte in diese eingefügt.
– Die Spalten zwischen den einzelnen Feldern des Storyboards wurden breiter (6 statt 4 Pixel), damit man mit der Maus leichter in den Spalt trifft, um dort Objekte einzufügen.
– Beim Hinzufügen von Pool-Objekten ins Storyboard werden die neu angelegten Felder im Storyboard selektiert.
– Es gibt einen neuen Effekt „Gaußscher Weichzeichner (mit Alphakanal)“. Dieser ermöglichst die Weichzeichnung von Inhalten mit Alphakanal. Der bisherige Gaußsche Weichzeichner wurde mit dem Namenszusatz „(ohne Alphakanal)“ erweitert. Ein wichtiger Unterschied ist die maximale Weichzeichnung, denn beim Weichzeichner mit Alphakanal reicht diese bis 100% und ohne Alphakanal bis 1000%.
– Beim Auto-Ducking können nun Beginn der Abblendung und Beginn der Einblendung um jeweils bis zu fünf Sekunden nachvorne und hinten verschieben werden. Dazu gibt es die beiden neuen Audio-Einstellungen „Auto-Ducking-Abblendung startet bei…“ und „Auto-Ducking-Einblendung startet bei…“.
– Die Liste der letzten Projekte bzw. Favoriten im Dialog zum Erstellen eines neuen Projekts (Menüpunkt „Datei – Neu“) zeigt nun die Pfade der Dateien als Tooltip an. So wird auch bei sehr langen Pfaden, die nicht mehr in die Liste passen, der ganze Pfad angezeigt, wenn man die Maus über diesen Eintrag bewegt.
– Spuren mit den Eigenschaften „Audio-Ducking auslösen“ und „Audio-Ducking ignorieren“ werden nun im Spurkopf mit entsprechenden Symbolen gekennzeichnet.
– Bei den Tab-Reitern von Timelines und Storyboards kann nun im Kontextmenü die Farbe geändert werden.
– Mit der neuen GUI-Einstellung „Tab-Abdunklung bei Wiedergabe“ kann man die Stärke der Abdunklung von Timeline- und Storyboard-Tabs bei Wiedergabe festlegen. Diese bewirkt, dass sich laufende Timelines aufgrund ihrer leuchtenden Tab-Farben besser von den inaktiven Timelines bzw. Storyboards abheben.
– Die Hintergrundfarbe jeder Spur kann beliebig geändert werden. Der Farbselektor enthält auch den Alphakanal, so dass auch dezente Einfärbungen (die die alternierende Hintergrundfarbe der Spuren durchscheinen lassen) sehr einfach realisierbar sind.
– Bei der Farbe von Gruppenspuren kann nun auch der Alphakanal festgelegt werden, was dezente Einfärbungen erheblich erleichtert.
– Die Einstellungen „Schriftgröße“, „Laufweite“ und „Zeilenabstand“ bei Textobjekten sind nun per Schieberegler (statt numerischer Eingabe) einstellbar.
– In der Starter-Lizenz kann nun ein Storyboard hinzugefügt, entfernt und in einen neuen Bereich verschoben werden.

Behobene Fehler

– Beim Drag & Drop von mehreren Bildern aus dem Storyboard in die Timeline wurden nur dann Überblendungen erzeugt, wenn die Crossfade-Einstellung aktiv war.
– Drag & Drop von Dateien ins Storyboard wurde abgebrochen, wenn man die Dateien über die Toolbar des Storyboards gezogen hat.
– Bei manchen Storyboard-Feldern (z.B. Audio) hatte der Text u.U. Doppelkonturen.
– Bei aktivierter Einstellung „Screen – Beim Editieren – Verschieben von Objekten überall zulassen“ konnte der sichtbare Screen-Ausschnitt mit der „P“-Taste nur beim Anklicken der rechteckigen Fläche „Position“ im Screen verschoben werden.
– Beim Verschieben von Pool-Ordnern wurde der Ordner u.U. eine Zeile zu weit hoch verschoben.
– Die Einstellungen für Audio-Plugins werden nur noch in der Pro-Lizenz angezeigt.

Version 1.2.0 vom 21.11.2022

Neue Funktionen

– Erste Version mit Storyboard (ein Storyboard in der Starter-Lizenz, beliebig viele Storyboards ab Advanced-Lizenz). Das Tutorial-Video ist über den Hilfe-Button in der Toolbar des Storyboards erreichbar.
– Es gibt nun einen Audio Peak Search für selektierte Objekte, Timelines und Timeline-Ausschnitte. Er ist über das Menü „Export – Audio Peak Search“ und über das Kontextmenü von Audio- und Video-Objekten erreichbar. Der Audio Peak Search ermittelt sowohl den höchsten Spitzenpegel pro Kanal als auch die jeweiligen maximalen RMS-Werte.
– Wenn der Audio Peak Search für selektierte Objekte durchgeführt wird, kann im Anschluss der Audiopegel dieser selektierten Objekte gemeinsam geändert werden.
– Im Kontextmenü von selektierten Audio- und Video-Objekten gibt es nun den Punkt „Lautstärke ändern…“ sofern mehr als ein Objekt selektiert ist. Damit kann der Audiopegel dieser selektierten Objekte gemeinsam geändert werden.
– Die Einstellung des Audio-Pegels im Eigenschaften-Panel erfolgt nun per Schieberegler (statt Eingabe von Zahlenwerten).
– Es gibt ein neues Auto-Ducking (ab Starter-Lizenz), um das Ducking automatisch über Audio-Objekte zu steuern. Dazu gibt es für jede Spur zwei neue Optionen im Eigenschaften-Panel: „Audio-Ducking auslösen“ und „Audio-Ducking ignorieren“. Es sind zwei unabhängige Einstellungen, die im Falle einer „Sprecherspur“ beide aktiviert werden. Dann lösen die Audio-Objekte auf dieser Spur das Ducking aus und diese Spur selbst ist vom Ducking ausgenommen. Im Falle einer „Specherspur“ würde also der gesprochene Text den restlichen Ton dynamisch absenken, so wie man es bei Live-Kommentar mit der Ducking-Funktion sonst manuell macht. Die zweite Option „Audio-Ducking ignorieren“ könnte aber auch für andere Anwendungsfälle sehr nützlich sein, denn vielleicht will man weitere Spuren (z.B. leise Hintergrund-Atmo) nicht vom Ducking absenken lassen.
– Die neue Audio-Einstellung „Manuelles Ducking – Priorität für manuelles Live-Ducking“ ermöglicht, bei automatischem Ducking von Audio-Objekten dem manuellen Live-Ducking per Toolbar, Tastaturshortcut oder Trigger den Vorrang zu geben.
– Es gibt den neuen Effekt „Gaußscher Weichzeichner“, der die Weichzeichnung des Bildinhalts mit besonders hoher Qualität bei deutlich reduzierter GPU-Belastung ermöglicht. Der bisherige Weichzeichner ist nicht mehr verfügbar und wird beim Laden eines Projekts automatisch durch den neuen Gaußschen Weichzeichner ersetzt.
– Die Beschriftung der „Ein/Aus“-Umschaltung bei den Effekten „Alpha-Wipe“ und „Seite umblättern“ wurde verständlicher gestaltet und weist nun auf den Schieberegler-Charakter hin.
– Der Effekt „Schärfen“ ist nun in jeder Lizenz (statt erst ab der Advanced-Lizenz) enthalten.
– Im Kontextmenü zum Erstellen neuer Marker können nun auch Pause-Marker für alle selektierten Objekte angelegt werden.
– Beim Öffnen des Screens oder der Vollbild-Umschaltung wird nun der Tastatur-Fokus dem Screen zugeordnet. Damit funktioniert z.B. die Leertaste für die Play/Pause-Umschaltung auch ohne explizit in den Screen zu klicken.
– Beim Export einer Timeline als Video, Audiodatei, Bildsequenz, etc. lässt sich nun die Ausgabe auf die selektierten Objekte beschränken. Die anderen Objekte werden dann für den Export temporär deaktiviert.
– Die Funktion „Timeline-Objekte selektieren“ im Pool gibt es nun auch für Bildfelder. So lässt sich komfortabel feststellen, welchen Objekten ein Bildfeld zugewiesen ist.
– Steuerspuren (Position/Zoom, Rotation, etc.) können per Kontextmenü in der Steuerspur selbst entfernt werden, wobei dies nun optional auf alle selektierten Objekte wirkt.
– Es gibt eine neue Einstellung „Pool – Player für Video-Vorschau“. Damit können Videos aus dem Dateibrowser bzw. Pool in einem externen Video-Player (z.B. VLC-Player) statt im Preview abgespielt werden. Dies ist besonders dann hilfreich, wenn das Betriebssystem die eigenen Videos nicht abspielen kann.
– Die neue Einstellung „Pool – Standard-Applikation von macOS/Windows verwenden“ ermöglicht die Wiedergabe von Videos aus Dateibrowser/Pool in dem Video-Player, der auf dem Betriebssystem als Standard-Player eingerichtet ist. Es ist also dieselbe Funktion wie ein Doppelklick auf ein Video im Finder/Explorer.
– Beim Export von Einzelbildern oder Bildsequenzen wird nun unabhängig vom Alphakanal des Screen-Inhalts auch bei 32 Bit Farbtiefe immer ein opakes Bild gespeichert.
– Bei den Symbolen im Dateibrowser für Trigger und Storyboard wird nun das konkrete Symbol als Icon (anstelle eines generischen Icons) angezeigt.
– Die Überblendcharakteristik (Linear, S-Kurve mit verschiedenen Neigungen) neuer Timeline-Objekte lässt sich nun für jede Art von Objekten (Audio, Bilder, Videos, Texte) in den Einstellungen vorgeben.
– Dateien im Pool, die zwar vorhanden sind aber nicht die erwarteten Eigenschaften aufweisen, werden nun gelb markiert. In diesem Fall sollten unbedingt die Datei-Eigenschaften aktualisiert werden, um weiteren Problemen vorzubeugen.
– Beim Aktualisieren von Datei-Eigenschaften im Pool werden nun veraltete Grafikdaten zuverlässiger erkannt und neu erstellt.
– Bei den Bildobjekten in der Timeline werden nun die Bilder ab Beginn der Standzeit (also am Ende der Einblendung anstatt am Objektbeginn) angezeigt. Dadurch ist die Einblendkurve einfacher zu erkennen und zu bearbeiten.
– Es gibt den neuen Trigger „System – Computer ausschalten“.
– Es gibt einen neuen Trigger zum Starten einer Präsentation im Pause-Modus im Vollbildscreen: „Timeline – Präsentation im Vollbildmodus“. Das Verhalten dieses Triggers entspricht etwa dem Start einer Präsentation mit der F5-Taste in Wings 7.
– Beim Export von Videos ist nun die Audioqualität unabhängig von der eingestellten Videoqualität intern immer auf Einstellung „Sehr hoch“. Dadurch ist auch bei platzsparenden Videos mit niedrigerer Qualität der Ton immer optimal.
– Die Einstellung „Thumbnailgröße“ wurde in „Thumbnailauflösung“ umbenannt, damit die Funktion klarer wird.
– Wenn das Einrasten in der Timeline aktiv ist, rastet der Locator nun immer an den Markern der aktiven Markerspur, egal ob diese Spur selektiert ist oder nicht.
– Wenn bei einem Crossfade der Einblendknotenpunkt verschoben wird, dann wird die rechte Kante (also das Ende) des „ausblendenden“ Objekts mitverschoben. Dadurch lassen sich Überblendzeiten wesentlich schneller ändern als vorher, weil man nicht erst das „ausblendende“ Objekt selektieren muss. Zur besseren Übersicht und als Erkennungsmerkmal dieser Operation wird dabei die Objekt-Transparenz automatisch aktiviert.
– Wenn „Folgeobjekte verschieben“ aktiv ist, können Timeline-Objekte nur noch horizontal verschoben werden.
– Bei Längenänderungen von Objekten durch Ziehen der rechten Kante werden nun bei aktivem „Folgeobjekte verschieben“ ggf. die folgenden Objekte auf allen ebenfalls selektierten Spuren auch verschoben.
– Das Verschieben von Objekten wurde intern komplett überarbeitet.
– Im Kontextmenü von Bild-Objekten in der Timeline gibt es den neuen Menüpunkt „Zeiten als Standard übernehmen“. Damit können die „Bilder“-Programm-Einstellungen für Objektdauer, Einblendzeit und die Option standardmäßig auch auszublenden von diesem Objekt übernommen werden.
– In den Einstellungen für Bilder können nun die Standardzeiten (Dauer und Einblendzeit) auf die Tausendstelsekunde (statt Zehntelsekunde) genau angegeben werden. Dies ist z.B. für schnelle Bildsequenzen nützlich.
– Beim Anlegen eines neuen Projekts wird nun der Locator immer auf die Standardposition zurückgesetzt.
– In den Programm-Einstellungen gibt es nun die Möglichkeit, beliebige Optionen als Favoriten zu markieren. Diese können dann auf Knopfdruck angezeigt werden. Somit kann sich jeder komfortabel seine Liste der am häufigsten benötigten Einstellungen für blitzschnellen Zugriff zusammenstellen.
– Es gibt auch für die Programm-Einstellungen einen Solo-Modus (wie im Eigenschaften-Panel).
– Im Leuchtpult wird nun (wie bisher schon in der Listendarstellung) die Verwendung eines Objekts getrennt nach Timeline (TL) und Storyboard (SB) angezeigt
– Das automatische Audio-Ducking wird nun auch beim Audio-PeakSearch und beim Export angewendet.
– Beim Entfernen eines selektierten Kurvenpunktes/Keyframes werden ggf. auch die anderen selektierten Punkte/Keyframes entfernt.
– Der Audio-Masterregler wirkt auch auf Peak Search und Export.
– Die Einstellung des Audio-Masterreglers wird im Projekt gespeichert und überschreibt beim Laden die aktuelle Einstellung.
– Die Ducking-Einstellungen „Absenkung“, „Abblendzeit“ und „Einblendzeit“ werden im Projekt gespeichert und überschreiben beim Laden eines Projekts die aktuellen Programm-Einstellungen.
– Storyboards haben nun eine Kopfzeile für die Einstellung von Dauer/Überblendzeit von Bildern, die in eine Timeline gezogen werden. Außerdem kann in der Kopfzeile nach Sternbewertungen gefiltert werden. Felder, deren Bewertung unter der eingestellten Filter-Bewertung liegt, werden abgedunkelt.
– Die Bedien-Elemente im Eigenschaften-Panel können nun Hilfe-Buttons haben. Den Anfang macht die Asynchron-Einstellung von Audio-Objekten.
– Im Lizenz-Dialog kann man nun das Passwort bei der Eingabe anzeigen lassen, so dass man Tippfehler sofort erkennen kann.
– Die interne Lizenzabfrage wurde so geändert, dass Wings X nach der letzten Nutzung mit Internet-Verbindung mindestens 13 Tage ohne Internet verwendet werden kann. Bisher waren dies nur 7 Tage. Die genaue Information über die Gültigkeitsdauer der lokal zwischengespeicherten Lizenz finden Sie jederzeit im Info-Dialog (Menüpunkt „Hilfe – Über Wings X“).

Behobene Fehler

– Beim Effekt „Teiltonung“ wurden die Parameter-Bezeichnungen korrigiert.
– Beim Überblenden auf dem Content-Stapel und dynamischer Maskierung wurden u.U. die überblendenden Inhalte leicht transparent.
– Videos hatten bei aktiver Video-Beschleunigung vereinzelt oben und rechts einen grünen Rand mit einer Breite von einem Pixel.
– Das Zurücksetzen der Spaltenbreiten im Pool mit der Alt-Taste hat u.U. nicht funktioniert.
– Beim Import von Wings 7-Projekten wurden die Steuerpuren (Position, Rotation , …) zwar korrekt importiert, aber beim Speichern gingen diese u.U. verloren.
– Beim gleichzeitigen Einsatz mehrerer dynamischer Masken mit weichen Alpha-Verläufen haben sich die Alphakanäle gegenseitig beeinflusst. Dadurch wurden u.U. ansonsten unsichtbare Bildkanten sichtbar.
– Videos mit ungewöhnlichen Größen konnten u.U. nicht wiedergegeben werden.
– Wenn von einem gepitchten Video links ein Teil abgeschnitten wurde, startete der verbleibende Teil an einer falschen Position.
– Die Start-/Endpunkte von Objektkurven konnten mit gedrückter Alt/Option-Taste per Mausklick gelöscht werden.

Version 1.1.4 vom 05.10.2022

Neue Funktionen

– Videos können nun gepitched (also in der Geschwindigkeit angepasst) werden (ab Advanced-Lizenz). Dazu muss für das Video der Wiedergabe-Modus „Nur Video“ eingestellt werden oder das Video enthält überhaupt keinen Ton (z.B. Zeitraffer-Videos). Erst dann erscheint die Pitch-Einstellung in den Video-Eigenschaften im Eigenschaften-Panel.
– Wenn der Pitch eines Videos erhöht wird, dann wird während der Pitch-Einstellung per Schieberegler der rechte Bereich des Video-Objekts rot markiert, der beim gewählten Pitch abgeschnitten wird, weil die resultierende Video-Laufzeit für das Objekt nicht ausreicht.
– Das Zuweisen von Bildfeldern, Effekten, Color-Gradings (LUTs) und Videomasken kann optional für alle selektierten Objekte erfolgen.
– Wenn beim Kopieren von Effekten und Kurven in den Pool kein passender Ordner vorhanden ist, so wird automatisch ein entsprechender Standard-Ordner auf der höchsten Ebene (also außerhalb aller anderen Ordner) angelegt.
– Beim Einstellen der Standardhöhe einer selektierten Spur werden alle ebenfalls selektierten Spuren auch auf ihre jeweilige Standardhöhe gesetzt.
– Der Menüpunkt „Bearbeiten – Auswahl aufheben“ kann nicht mehr während der Wiedergabe aufgerufen werden.

Behobene Fehler

– Im Export-Dialog konnten u.U. bei wechselnden Seitenverhältnissen Inkonsistenzen bei der Ausgabegröße auftreten.
– Standbilder ohne Effekte konnten u.U. bei der Video-Ausgabe flackern.
– Die Einzelbildausgabe an der Locatorposition war für Standbilder ohne Effekte nicht möglich.
– Beim Öffnen von Autosave-Projekten unter macOS mussten u.U. auch die vorhandenen Pool-Dateien gesucht werden.

Version 1.1.2 vom 30.09.2022

Neue Funktionen

– Die Funktion „Unbenutzte Pool-Objekte entfernen“ wurde derart geändert, dass nur noch unbenutzte Datei-Objekte (also Audio, Bilder, Video, Texte, und Color-Gradings) entfernt werden. Alle anderen Typen von Pool-Objekten (Bildfelder, Trigger, Effekt, …) werden von dieser Funktion nicht mehr entfernt. Daher wurde die Funktion in „Unbenutzte Dateien entfernen“ umbenannt.

Version 1.1.1 vom 29.09.2022

Neue Funktionen

– Der neue Effekt „Rahmen im Bild“ ermöglicht einen Rahmen innerhalb des Bildinhalts zu setzen. Mit Animation der Rahmenbreite und ggf. transparenter Farbe kann dieser Effekt auch genutzt werden, um Bildinhalte erscheinen oder verschwinden zu lassen.
– GIF-Bilder können als Standbilder verwendet werden. Die Verwendung von animierten GIFs als Video wird dagegen nicht unterstützt.
– Beim Import von Wings 7 wird bei Videos die Audiospur deaktiviert, weil Videos in Wings 7 keine integrierte Audiowiedergabe hatten.

Behobene Fehler

– Beim Effekt „Rahmen“ war die Breite oben/unten unter bestimmten Umständen nicht identisch mit der Breite links/rechts.

Version 1.1.0 vom 28.09.2022

Neue Funktionen

– Dies ist erste Version mit Echtzeit-Effekten.
– Der Solo-Modus im Eigenschaften-Panel ist nun per Button umschaltbar.
– Es gibt eine neue Screen-Option, um den Screen beim Öffnen eines Projekts immer geschlossen zu halten.
– Im Info-Dialog zur Demoversion wird darauf hingewiesen, dass Demo-Projekte nur mit Pro-Lizenzen geöffnet werden können.
– Das Rotations-Zentrum kann nun mit zwei Schiebereglern horizontal und vertikal verschoben werden. Dabei entspricht eine Verschiebung um 50% einer Platzierung des Zentrums exakt am Objektrand. Bei einer Verschiebung um 100% befindet sich das Rotationszentrum um eine ganze Objektbreite/höhe außerhalb des Zentrums. Es gibt noch keine optische Anzeige des Rotationszentrums. Diese wird in einem der nächsten Updates implementiert.
– Die Einstellung der Werte für Zoom und XY-Skalierung geschieht nun mit Schiebereglern statt Eingabefeldern.
– Die Einstellung der SmartMove-Werte geschieht nun mit Schiebereglern statt Eingabefeldern.
– Beim Zurücksetzen der SmartMove-Werte wird der Standardwert aus den Einstellungen berücksichtigt.
– Im Hilfe-Menü gibt es einen direkten Link zum Workbook der Wings X MasterClass, wenn die Verlinkung der MasterClass-Hilfe in den Einstellungen unter „Benutzeroberfläche – Wings X MasterClass“ aktiviert ist.
– Neues Hilfe-Icon in der Toolbar.
– Der Farb-Selektor zeigt auch HSB-Werte an.
– Die Einstellung von Farben im Eigenschaften-Panel hat nun ein Live-Update. D.h. die Farben werden im Screen bei Änderungen live aktualisiert.
– Die Farb-Einstellungen im Eigenschaften-Panel visualisieren auch den Alphawert mittel ggf. durchscheinendem Schachbrettmuster.
– Aktivierte Toolbar-Buttons sind an der gelben Farbe erkennbar und haben nun keinen umlaufenden Rand mehr.
– Es gibt eine neue Einstellung „Benutzeroberfläche – Eigenschaften-Panel – Farb-Transparenzen mit Schachbrettmuster anzeigen“. Damit können eventuelle Transparenzen von Farben visualisiert werden. Bei stark durchscheinenden Farben ist dann allerdings die Farbe schwerer erkennbar.
– Im Eigenschaften-Panel können Sektionen auch im Solo-Modus durch Klick geschlossen werden.
– In den Einstellungen ist die Pool-Option „Beim Selektieren in die Mitte eines Timeline-Objekts springen“ nun per Default aktiviert.

Behobene Fehler

– Skalierungs-Steuerspuren konnten nicht in den Pool kopiert werden.

Version 1.0.11 vom 22.08.2022

Neue Funktionen

– Im Eigenschaften-Panel wird beim Anklicken einer Sektion mit gedrückter Strg-/Command-Taste diese Sektion geöffnet und alle anderen geschlossen (ähnlich wie beim Solo-Modus von Lightroom). Es ist also in diesem Fall immer nur die angeklickte Sektion geöffnet, was für mehr Übersicht sorgt.
– Die Informationen zum Import von Wings 7-Projekten wurden um die Übernahme der Eigenschaften dynamischer Masken erweitert.

Behobene Fehler

– Der Import von Wings 7-Projekten konnte bei Farbsteuerspuren abstürzen.
– Aus Wings 7 importierte Objekte bekamen u.U. eine Farbsteuerspur, die in Wings 7 jedoch nicht programmiert war.

Version 1.0.10 vom 10.08.2022

Neue Funktionen

– Dynamische Masken sind ab der Advanced-Lizenz verfügbar. Angelehnt an Wings 7 können in der Advanced-Lizenz dabei einzelne Masken verwendet werden. In der Pro-Lizenz steht dagegen ein kompletter Maskenstapel zur Verfügung, mit dem beliebig komplexe dynamische Masken aus mehreren Masken kombiniert werden können. Außerdem ist in der Pro-Lizenz das invertierte Rendern des Maskenstapels möglich.
– Die Zuordnung der Objekte bei Nutzung der dynamischen Masken zu Content-Stapel, Maskenstapel, etc. geschieht nun in den Objekt-Eigenschaften und nicht mehr wie bei Wings 7 in den Spur-Eigenschaften. Damit ist die Handhabung wesentlich einfacher und flexibler geworden.
– Beim Import aus Wings 7 werden die Spur-Eigenschaften der dynamischen Masken auf die entsprechenden Objekte in Wings X übertragen.
– Es ist nun möglich, Objekte im Screen getrennte horizontal/vertikal zu skalieren. Dazu gibt es in den Objekt-Eigenschaften den neuen Abschnitt „Skalierung“.
– In den Objekt-Eigenschaften kann unter „Steuerspuren“ eine Steuerspur für die getrennte Skalierung aktiviert werden, so dass die Skalierung auch dynamisch gesteuert werden kann.
– Die getrennte Skalierung ist auch im In-Screen-Editing möglich, wenn beim Zoomen die „H“ bzw. „V“-Taste gedrückt gehalten wird.
– Bei der Einzelbildausgabe kann optional eine gleichnamige LUT erstellt werden. Damit befindet sich im Falle des Exports eines Videoframes für das Color-Grading die Referenz-LUT direkt „neben“ dem Einzelbild im selben Ordner. Dazu wird an den Dateinamen des Einzelbilds „\_LUT“ angehängt.
– Beim Aktualisieren der Datei-Eigenschaften von Pool-Objekten wird nun ggf. der Screen geschlossen und anschließend wieder geöffnet, damit geänderte Inhalte gleich sichtbar werden.
– Wenn im Pool mehrere Objekte selektiert sind, dann wirkt das Aktualisieren der Datei-Eigenschaften auf alle ebenfalls selektierten Objekte (und nicht nur auf das angeklickte Objekt).

Version 1.0.7 vom 13.07.2022

Neue Funktionen

– Projekte von Wings 7 können mit Advanced- und Pro-Lizenz importiert werden.
– Bei Bildern, die als Masken für Videos verwendet werden, werden bei Aufruf von „Timeline-Objekte selektieren“ auch die Videos in der Timeline selektiert.
– Bei Lookup-Tables (LUTs) selektiert nun der Aufruf von „Timeline-Objekte selektieren“ alle Bilder und Videos Timeline, denen diese LUT zugewiesen ist.
– Die Stärke einer Video-Maske kann mit einem Schieberegler (statt Eingabe von Zahlenwerten) gesteuert werden.
– Das Color-Grading mittels LUT, die einer Spur zugewiesen ist, kann mit einem Schieberegler (statt Eingabe von Zahlenwerten) gesteuert werden.
– Timeline-Tabs können per Kontext-Menü nach links/rechts bzw. an den Anfang und ans Ende verschoben werden.
– Ein neues Hilfe-System ermöglicht direkte Hilfestellung an bestimmten Stellen der Benutzeroberfläche. In der Hilfe werden ggf. auch weiterführende Links zu Tutorials, etc. angezeigt. Das erste Beispiel für eine solche Hilfe findet sich beim Import von Wings 7 Projekten.
– Es gibt eine neue Einstellung unter „Benutzeroberfläche“ zur Verlinkung der „Wings X MasterClass“. Wenn diese Einstellung aktiviert ist, werden in der Hilfe auch die zugehörigen Informationen in der Wings X MasterClass verlinkt. Somit erreicht man mit einem Mausklick die entsprechenden Informationen in der MasterClass und erspart sich das separate Öffnen und Suchen nach Begriffen. Die Wings X MasterClass funktioniert dann mit dem Komfort einer kontextsensitiven Hilfe.

Behobene Fehler

– Beim Undo einer LUT-Zuweisung wurde diese u.U. nicht korrekt aufgehoben, so dass die direkte erneute Zuweisung derselben LUT nicht möglich war.
– Fehlende LUT-Dateien wurden im Pool nicht rot markiert.
– Beim Ziehen einer LUT auf ein Timeline-Objekt war u.U. die Teilung der LUT-Vorschau nicht mittig.
– Beim Sprung-Marker war die Eingabe eine Ziel-Markers u.U. nicht möglich.

Version 1.0.5 vom 13.06.2022

Neue Funktionen

– Bilder können in Wings X Pro als Alpha-Masken für Videos verwendet werden. Dazu muss man lediglich ein Bild aus dem Pool auf ein Video-Objekt in der Timeline ziehen. Schwarzweiß-Bilder werden direkt als Alpha-Kanal interpretiert. Bei Bildern mit 32 Bit Farbtiefe wird deren Alpha-Kanal benutzt und bei Bildern mit 24 Bit wird das Bild in schwarzweiß konvertiert und als Maske benutzt.
– Die Alpha-Maske für ein Video kann in der Deckkraft beeinflusst werden. Dazu gibt es den Parameter „Deckkraft“ in den Objekt-Eigenschaften. Bei einer Einstellung auf „0%“ hat die Maske keine Auswirkung und bei „100%“ hat sie die volle Deckkraft.
– Die Video-Performance des gängigsten Formats (YUV, 8 Bit) ist erheblich besser als bisher.
– Im Video-Pool gibt es eine neue Spalte „Modus“. Hier kann man die automatische Video-Optimierung (Modus „Optimiert“) ausschalten, falls diese zu Fehlern führen sollte (Modus „Kompatibel“ wählen).
– Beim Start einer Timeline in einem Video wird nun max. zwei Sekunden gewartet, bis die Position im Audiostream gefunden und die benötigten Samples vorgeladen wurden.
– Es gibt (ab der Advanced-Lizenz) Color-Grading für Videos und Bilder mit Lookup-Tabellen (LUTs). Dieses Verfahren ist ein Standard in der Video-Welt und ermöglicht beliebig komplexe Manipulationen an Farben, Tonwerten, Kontrasten, etc. mit einer LUT-Datei.
– Es gibt eine neue Kategorie bzw. neue Ordner „Color-Grading“ im Pool. Hier können die LUT-Dateien eingefügt/verwaltet werden. Es werden die Formate „CUBE“ und „3DL“ akzeptiert, wobei CUBE das meistverwendete Standard-Format ist.
– Color-Gradings/LUTs werden wie Bildfelder verwendet. Man kann sie auf Spuren und auf Timeline-Objekte (Bilder und Videos) ziehen. Wenn einem Objekt ein Color-Grading zugewiesen wurde, dann hat dieses Vorrang gegenüber einem Color-Grading, das der Spur zugewiesen ist. Dies entspricht der Logik bei Bildfeldern.
– Beim Ziehen von Color-Gradings/LUTs auf ein Objekte oder einen Spurkopf erscheint der betreffende Screen-Inhalt zweigeteilt mit einer Vorher/Nachher-Ansicht bis man die Maustaste loslässt und das Color-Grading zugeweisen ist. Auf der linken Seite der geteilten Ansicht sieht man das Original-Bild/Video (also ohne LUT) und auf der rechten Seite wird was Bild/Video mit angewendeter LUT angezeigt. So kann man leicht die Wirkung der LUT am betreffenden Objekt ausprobieren
– Das Color-Grading kann über den Parameter „Stärke“ in den Objekt-Eigenschaften beeinflussst werden. Bei einer Einstellung auf „0%“ hat das Color-Grading keine Auswirkung und bei „100%“ hat es die volle Wirkung.
– Wenn einem Timeline-Objekt ein Color-Grading zugewiesen ist, erscheint in der Infozeile ein entsprechendes Symbol (Farbpalette)
– Wenn eine Spur Audio-Plugins oder Color-Grading enthält, dann erscheinen entsprechende kleine Symbole im Spurkopf.
– Wings X kann Lookup-Tabellen fürs Color-Grading in Verbindung mit einer beliebigen Bildbearbeitungs-Software (z.B. Lightroom, Photoshop, …) selbst erstellen. Es wird keine zusätzliche Spezialsoftware benötigt.
– Der Mauszeiger wird bei laufender Timeline im Screen nach einer Sekunde versteckt, wenn er nicht bewegt wird.
– Die Bildfeld-Option „Nur Position“ wurde entfernt, da sie im Zuge von Weiterentwicklungen des Screens keinen Sinn mehr macht.
– Wenn einem Dateityp kein Editor zugewiesen ist, dann kann die Datei in der Standard-Anwendung geöffnet werden.
– Die Spaltenbreiten im Pool wurden überarbeitet.

Behobene Fehler

– ScreenTrigger wurden u.U. nicht ausgeführt, wenn mehrere ScreenTrigger-Objekte gleichzeitig in einer Timeline positioniert waren.
– Beim Drag & Drop von Dateien auf bestehende Timeline-Objekte wurden u.U. irreführende Hinweise im Timeline-Objekt angezeigt.
– Die Audio-Wiedergabe von WMV-Videos hat u.U. nicht funktioniert.
– Der Video-Export blieb u.U. stecken, wenn fehlerhafte Videos im Projekt verwendet wurden.

Version 1.0.3 vom 02.05.2022

Neue Funktionen

– Wenn die Grafikdaten von Audio-Objekten fertig erstellt wurden, dann werden diese jetzt gespeichert und beim nächsten Mal direkt von der Festplatte geladen. Dies macht sich am deutlichsten bei langen Videos bemerkbar, weil der Ton erst aus dem Video extrahiert und decodiert werden muss und nicht direkt z.B. als Wave-Datei vorliegt. Bei diesen Videos geht es daher nun extrem viel schneller bis die die Anzeige der gesamten Audio-Grafikdaten in der Timeline sichtbar ist.
– Video-Objekte speichern nun ihre Thumbnails auf der Festplatte, damit sie nur einmal erstellt werden müssen und dann immer direkt geladen werden können. Bei „normalen“ Videos war bisher schon die Erstellung der Thumbnails in der Timeline extrem schnell, aber es gibt auch Videos, bei denen dieser schnelle Lademechanismus nicht funktioniert, und diese benötigen erheblich länger bei der Erstellung der Thumbnails. Mit der Speicherung der Thumbnails ist deren Erstellung nur noch ein einziges Mal erforderlich und ab dann stehen die Thumbnails ohne wahrnehmbare Wartezeit zur Verfügung.
– Die Speicherung von Audio-Grafikdaten und Video-Thumbnails führt beim Öffnen eines komplexen Projekts mit vielen Videos zu einer sehr deutlichen Geschwindigkeitssteigerung und die hohe CPU-Last ist sofort nach dem Laden beendet. Somit steht unmittelbar nach dem Öffnen eines Projekts die gesamte Rechenleistung zum Editieren und Präsentieren zur Verfügung.
– Es gibt einen neuen Menüpunkt „Timeline – Ab Locator verschieben“. Der Tastatur-Shortcut dafür ist „Strg/Command + M“. Dies war bisher der Shortcut von „Zweiten Pool im Fenster öffnen“, dessen Shortcut nun auf „Shift + Strg/Command + M“ geändert wurde.
– Das Verhalten von Keyframes beim Verlängern/Verkürzen von Objekten wurde grundlegend geändert. Wenn der erste bzw. letzte Keyframe sich bereits am Rand des Objekts befindet, dann bleibt er dort auch verankert. Wenn beim Verlängern/Verkürzen Keyframes weggeschnitten werden, so wird der jeweils letzte Keyframe nicht entfernt sondern am jeweiligen Rand verankert.
– Das interne Handling der Verschiebung von Timline-Objekten wurde überarbeitet, um auch in komplexen Situationen zu nachvollziehbaren Ergebnissen zu führen. Dies betrifft besonders Kombinationen von mehreren selektierten Objekten mit „Folgeobjekte verschieben“ und aktivem Crossfade-Modus.
– Der Text mit den Neuerungen im Update-Dialog ist besser lesbar.

Behobene Fehler

– Automatische Updates haben bei der Demoversion nicht funktioniert.
– Beim Erstellen von Video-Thumbnails wurde u.U. Speicher (RAM) verbraucht und nicht mehr freigegeben.
– Die Anzeige von fehlenden Dateien wurde u.U. nur im internen Pool und nicht im separaten Pool im Fenster aktualisiert.
– Wenn bei vertikal gescrollter Timeline Spuren oder Objekte über die erste sichtbare Spur gezogen wurden, dann wurden diese letzten Endes vor der ersten Spur eingefügt.

Version 1.0.1 vom 27.04.2022

Neue Funktionen

– Es kann ein zweiter Pool in einem separaten Fenster geöffnet werden, welches frei platziert werden kann. Beide Pools können parallel genutzt werden. Zum Öffnen des zweiten Pools gibt es den Menüpunkt „Pool – Zweiten Pool im Fenster anzeigen“ oder den Tastatur-Shortcut „Strg/Command + M“.
– Es gibt einen neuen Kurven-Pool für Kurven und Steuerspuren. Bei bereits bestehenden Projekten muss ein Kurven-Ordner ggf. manuell hinzugefügt werden.
– Kurven und Steuerspuren können per Kontextmenü-Eintrag in den Kurven-Pool kopiert werden und von dort per Drag&Drop Objekten zugewiesen werden.
– Der Kurven-Pool hat auch eine Leuchtpultansicht.
– Der Wert eines Knotenpunkts, der gerade mit der Maus verschoben wird, erscheint in der Infozeile ganz links. Die Anzeige erfolgt in Prozent oder Dezibel je nach Typ des Objekts.
– Beim In-Screen-Editing werden die bearbeiteten Werte live in der Infozeile der editierten Objekte angezeigt.
– Es gibt eine neue Screen-Einstellung, um die Positionswerte beim In-Screen-Editing in der Infozeile der Objekte nicht nur in Pixeln sondern zusätzlich in Prozent anzuzeigen.
– Die Verschiebeschwellen mit Shift-Taste beim In-Screen-Editing für Verschiebungen in nur eine Richtung wurden sehr deutlich (auf Zehntel des bisherigen Wertes) verkleinert. Damit erfolgt das Einrasten beim Editieren mit Shift-Taste sehr viel schneller nachdem die Mausbewegung gestartet wurde.
– Die Bedienung des In-Screen-Editing wurde überarbeitet. Es gibt nun drei Buchstaben-Tasten, die ähnlich wie in der Timeline funktionieren:
– „G“ aktiviert das Einrasten an Positionen, Winkeln, etc. und funktioniert genau wie in der Timeline (gedrückt halten für temporäre Aktivierung und schnell doppelt drücken für dauerhafte Aktivierung).
– „H“ und „V“ begrenzen Verschiebungen horizontal und vertikal.
– Die Standard-Rastpositionen im Screen wurden von 100 Pixel auf praxisgerechtere 10 Pixel reduziert.
– Bild-Objekte mit Alpha-Kanal haben eine neue Einstellung „Alpha ist vormultipliziert“ im Eigenschaften-Panel. Damit kann auf die Darstellung des Alphakanals Einfluss genommen werden. Diese Einstellung wird beim Erstellen von neuen Bild-Objekten automatisch in Abhängigkeit vom Dateiformat gesetzt und kann nachher vom Anwender (falls erforderlich) geändert werden.
– Wenn man Bilder mit Alphakanal in Wings X nutzen möchte, ist TIFF das empfehlenswerteste Format.
– Beim Verlängern/Verkürzen eines Objekts durch Verschieben des rechten Rands wird die Einstellung „Folge-Objekte verschieben“ berücksichtigt.
– Wenn Objekte mit „Links anschließen“ verschoben werden, wird die Einstellung „Folge-Objekte verschieben“ berücksichtigt.
– Die Timeline-Funktion „Lücken selektierter Objekte schließen“ verschiebt nachfolgende Objekte zusammen mit dem letzten selektierten Objekt, wenn die Einstellung „Folge-Objekte verschieben“ aktiv ist.
– WebP-Bilder können verwendet werden.
– Die Objekt-Eigenschaften „Position fixiert“ und „Bei Wiedergabe ignorieren“ sind nun auch im Kontextmenü eines Objekts verfügbar. Ist das angeklickte Objekt zusammen mit anderen Objekten selektiert, dann wirkt dies auf alle selektierten Objekte.
– Es gibt eine neue Pool-Einstellung für die Höhe der Elemente im Ordnerbaum. Damit können diese vergrößert werden, damit das Treffen mit der Maus beim Drag&Drop von Dateien einfacher wird.
– Am Rand eines Objekts liegende Knotenpunkte können nun deutlich leichter mit der Maus gefasst werden.
– Beim Zuklappen von Spurgruppen werden nun optional auch die enthaltenen Objekte deselektiert. Dies kann in den Timeline-Einstellungen geändert werden.
– Beim Öffnen des Vollbildscreens erscheint ein deaktivierbarer Hinweis, mit welchen Tasten-Kombinationen man den Screen wieder schließen kann.
– Aktivierte Toolbar-Buttons erscheinen nun mit gelbem Symbol (wie im Dateibrowser).
– Der eingestellte Pegel eines Audio-Objekts wird in der Infozeile angezeigt.
– Die maximale Größe von Textdateien ist nun auf 10 kB beschränkt.

Behobene Fehler

– Beim Aktualisieren von Datei-Eigenschaften wurden u.U. unnötigerweise Thumbnails neu erstellt.
– Die Einstellung „Breite von Marker-Objekten“ wurde immer als geändert angezeigt.
– Die Schrift von Text-Objekten hatte unter ungünstigen Umständen eine Umrandung.
– Wenn ein Dialog offen ist, können keine Dateien mehr in Pool oder Timeline gezogen werden.
– Bildfelder konnten nicht an Textobjekte ohne Pool-Objekt zugewiesen werden.
– Beim (eigentlich nicht erlaubten) vertikalen Verschieben einer mehrspurigen Selektion von Objekten aus der Timeline heraus konnte es zum Absturz kommen.
– Nach dem Selektieren eines fixierten Objekts wurde die Zeitanzeige in der Infozeile beim Loslassen der Maustaste nicht mehr aufgehoben.
– Das Kontextmenü von Keyframes konnte nur aufgerufen werden, wenn mindestens zwei Keyframes in einer Steuerspur waren.
– Bei aktviertem Einrasten im Screen wurden u.U. andere als die gerade bearbeiteten Werte auf Rastpositionen gesetzt.
– Bei hochformatigen Screens waren die Button-Beschriftungen fürs In-Screen-Editing u.U. nicht lesbar.

Version 1.0 vom 18.04.2022

Erste offizielle Version

Dies ist die erste offizielle Version von Wings X.
Wings X ist ohne Registrierung als Demoversion zeitlich unbegrenzt nutzbar. In der Demoversion befindet sich im Screen ein Wasserzeichen, es können nur die ersten zwei Minuten eines Projekts editiert werden und die Wiedergabe stoppt automatisch nach zwei Minuten. Außerdem sind einige Funktionen wie Projekt-Backup und diverse Export-Methoden nicht verfügbar. Ansonsten eignet sich die Demoversion uneingeschränkt zum Ausprobieren von Wings X.

Neue Funktionen

– Der Start-Dialog wurde überarbeitet und ermöglicht nun die Auswahl des gewünschten Screen-Seitenverhältnisses.
– Doppelklick auf die Zeitanzeige einer Timeline ermöglicht die direkte Eingabe einer Zeit, zu welcher der Locator springen soll. Dabei ist es mit vorangestelltem „++“ oder „–“ möglich, relative Zeiten einzugeben. Beispiel: Eingabe von „++10“ springt von der aktuellen Position aus um zehn Sekunden weiter und „–20“ springt um 20 Sekunden zurück.
– Beim Löschen von zugeklappten Gruppenspuren werden nun auch die in der Gruppe enthaltenen (gerade nicht sichtbaren) Spuren mit gelöscht.
– Wenn beim Zu- oder Aufklappen von Gruppenspuren die Shift-Taste gedrückt ist, werden alle Gruppen zu- bzw. aufgeklappt.
– Die Buttons im Dateibrowser für „Aktualisieren“ und „Eine Ebene hoch“ haben ihr Plätze getauscht.

Behobene Fehler

– Einzelne Timeline-Objekte konnten nur entfernt werden, wenn sie selektiert waren.
– Screen-Trigger blieben bei Rücksprüngen in der Timeline aktiv.
– Das Schachbrettmuster hinter Bildern mit Transparenzen war in der Timeline bei längeren Objekten gegenüber dem Bildinhalt versetzt.
– Beim Verschieben von zugeklappten Spurgruppen ging u.U. die Zuordnung der Spuren zur Gruppe verloren.
– Bei Bildern mit Transparenzen wurde im Preview-Panel u.U. der Alphakanal weiß dargestellt.
– Beim Ziehen von Objekten aus dem Leuchtpult in die Timeline bleibt nun die Position im Leuchtpult auch erhalten, wenn diese vorher mit dem Mausrad verändert wurde.